淘小兔

电脑刚重装了Windows8.1系统,然后安装数据库的时候,却出现了这样的问题:您的电脑上的应用需要使用以下windows功能。

Windows无法安装以下功能:.NET Framework 3.5(包括 .NET 2.0 和 3.0)解决方法

问题原因是:在安装系统的时候,NET Framework 4.5 包含在 Windows 8.1 中,并随操作系统安装在您的计算机上。 但是,.NET Framework 3.5 不随着 Windows 8 一起自动安装。 若要在 Windows 8 上运行需要 .NET Framework 3.5 的应用程序,您必须在您的计算机上的启用版本 3.5。 有两种您可以执行此操作的方法:通过安装或运行需要 .NET Framework 3.5 的应用程序(即,通过在需要时安装 .NET Framework 3.5),或者通过启用控制面板中的 .NET Framework 3.5。 两个选项需要 Internet 连接。

解决方案:

第一种:通过internet下载,这里有两种方式。

(1)如上图,按照提示,直接点解”安装此功能“,可以实现安装。

(2)通过控制面板安装:

控制面板——程序和功能——打开或关闭Windows功能——点击Morcrosoft .NET Framework 3.51. ,确定。

Windows无法安装以下功能:.NET Framework 3.5(包括 .NET 2.0 和 3.0)解决方法

但是如果网络不好的话,一会就会出现下面的错误:
错误:

0x800f0906:“Windows 无法连接到 Internet 以下载必要的文件。 确保已连接到 Internet,然后单击“重试”以便再试。由于下列原因可能显示这些消息可能:您的计算机未连接到 Internet。 请连接,然后重试该操作。

但是安装了大约七八次都没有安装上去,利用第二种方法实现的。

 

第二种方法:
   
其实win8的iso上带着net 3.5的功能的,但是并没有随着系统安装二安装上去。将你装系统时候的Win 8镜像装载到一个盘符里面。装载后计算机里你就可以看见一个驱动器,记住它的盘符,后面要用到,如图。

装载win8 系统镜像:

Windows无法安装以下功能:.NET Framework 3.5(包括 .NET 2.0 和 3.0)解决方法

装载完成,盘符是J

 

 

Windows无法安装以下功能:.NET Framework 3.5(包括 .NET 2.0 和 3.0)解决方法

然后win+x,选择命令提示符(管理员)。在弹出的框里输入:dism.exe /online /enable-feature /featurename:NetFX3 /Source:j:\sources\sxs(ps:地址可以复制过去,以防出现错误)注意我的盘符是j,你要修改成你的盘符。然后回车,稍等几分钟就会安装完成,如下图所示。

Windows无法安装以下功能:.NET Framework 3.5(包括 .NET 2.0 和 3.0)解决方法

这样再去安装sql 的时候,就很顺利的安装上去了。

小结:

       还有安装VS的时候如果没有安装net framework 3.5  的话,那么也会出现这样的问题。装个系统搞得好麻烦,以后得记住备份个系统,这样的话,就可以省很多的时间,提高效率。

       参考官网的解决办法:windows功能无法安装以下功能:.NET Framework 3.5(包括.NET 2.0和3.0)

下载体验

请输入密码查看内容!

如何免费获取密码?
{donate}

 

点击下载